Sunday, March 5, 2017

Mikrotik Beep Song Indonesia: Apose

Sunday morning, composing "Apose" folk song from Biak, Papua, Indonesia on Mikrotik using beep command.
# Mikrotik beep song "Apose"
# Wahyu Wijanarko - http://wahyu.com
:beep length=300ms frequency=783.99
:delay 350ms
:beep length=300ms frequency=1046.50
:delay 350ms
:beep length=300ms frequency=1318.51
:delay 700ms
:beep length=300ms frequency=1174.66
:delay 175ms
:beep length=300ms frequency=1318.51
:delay 350ms
:beep length=300ms frequency=1174.66
:delay 175ms
:beep length=300ms frequency=1046.50
:delay 700ms
:beep length=300ms frequency=783.99
:delay 350ms
:beep length=300ms frequency=1046.50
:delay 350ms
:beep length=300ms frequency=1318.51
:delay 700ms
:beep length=300ms frequency=1318.51
:delay 175ms
:beep length=300ms frequency=1174.66
:delay 175ms
:beep length=300ms frequency=1318.51
:delay 175ms
:beep length=300ms frequency=1396.91
:delay 175ms
:beep length=300ms frequency=1174.66
:delay 700ms
:beep length=300ms frequency=783.99
:delay 350ms
:beep length=300ms frequency=987.77
:delay 350ms
:beep length=300ms frequency=1174.66
:delay 700ms
:beep length=300ms frequency=1396.91
:delay 175ms
:beep length=300ms frequency=1567.98
:delay 350ms
:beep length=300ms frequency=1396.91
:delay 175ms
:beep length=300ms frequency=1318.51
:delay 700ms
:beep length=300ms frequency=1174.66
:delay 175ms
:beep length=300ms frequency=1318.51
:delay 350ms
:beep length=300ms frequency=1174.66
:delay 175ms
:beep length=300ms frequency=1046.50
:delay 1400ms
:beep length=300ms frequency=783.99
:delay 350ms
:beep length=300ms frequency=1046.50
:delay 350ms
:beep length=300ms frequency=1396.91
:delay 350ms
:beep length=600ms frequency=1318.51
:delay 1400ms
:beep length=300ms frequency=783.99
:delay 350ms
:beep length=300ms frequency=987.77
:delay 350ms
:beep length=300ms frequency=1174.66
:delay 350ms
:beep length=600ms frequency=1046.50
:delay 1400ms
:beep length=300ms frequency=783.99
:delay 350ms
:beep length=300ms frequency=1046.50
:delay 350ms
:beep length=300ms frequency=1396.91
:delay 350ms
:beep length=600ms frequency=1318.51
:delay 1400ms
:beep length=300ms frequency=783.99
:delay 350ms
:beep length=300ms frequency=987.77
:delay 350ms
:beep length=300ms frequency=1174.66
:delay 350ms
:beep length=600ms frequency=1046.50

Tuesday, February 28, 2017

How to Block Youtube and Facebook Using Mikrotik DNS Cache

Create script to check DNS cache in Mikrotik, put ni system - scheduler, make it run every 1 minute.
:local ADDRLIST "BLOCKWEBSITE"
:local DOMAIN "youtube.com|facebook.com|fbcdn.net"
# Find CNAME record
:local DOMAINNAME
:foreach i in=[/ip dns cache all find where (name~"($DOMAIN)") && (type="CNAME") ] do={
  :set DOMAINNAME [/ip dns cache all get $i data];
  :set DOMAIN "$DOMAIN|$DOMAINNAME";
   delay delay-time=10ms
}
# Find A record
:foreach i in=[/ip dns cache all find where (name~"($DOMAIN)") && (type="A") ] do={
  :local DOMAINIP [/ip dns cache get $i address];
  delay delay-time=10ms
  :if ( [/ip firewall address-list find where address=$DOMAINIP] = "") do={
    /ip firewall address-list add address=$DOMAINIP list=$ADDRLIST timeout="00:10:00" comment=[/ip dns cache get $i name];
  }
}
Block request to public DNS outside Mikrotik
/ip firewall nat
add chain=dstnat action=dst-nat to-addresses=192.168.123.8 to-ports=53 protocol=tcp dst-port=53
add chain=dstnat action=dst-nat to-addresses=192.168.123.8 to-ports=53 protocol=udp dst-port=53
Block the desired IPs that already listed in address list
/ip firewall filter
add action=drop chain=forward comment="Block Website" disabled=no dst-address-list=BLOCKWEBSITE

Sunday, February 14, 2016

Gmail Check mail from other Gmail accounts (using POP3) Error

I tried using Gmail to check another Gmail account using POP3. The, I got email notification from them.
Sign-in attempt prevented.
Someone just tried to sign in to your Google Account from an app that doesn't meet modern security standards.

Details:
Saturday, February 13, 2016 7:22 PM (Eastern Standard Time)
United States*

We strongly recommend that you use a secure app, like Gmail, to access your account. All apps made by Google meet these security standards. Using a less secure app, on the other hand, could leave your account vulnerable.

Some users that user Gmail to fetch or backup another Gmail account experienced Gmail blocking Gmail with error in POP3 server. I also tried and get the error:

[AUTH] Web login required: https://support.google.com/mail/answer/14257

The solution is just simple, that is by "Allow less secure apps: ON".



They said that some non-Google apps and devices use less secure sign-in technology, which could leave your account vulnerable. You can turn off access for these apps (which we recommend) or choose to use them despite the risks.