Thursday, September 25, 2014

Random Contacs Missing from Android Phone

When on vacation, I got problem that my contacts were missing on Android phone. I store them all as Google contact. So, I checked what happen and then realized that I use more than 1 Google accounts synced contacts data to my phone contacts, and I found them tried to syncing almost forever.

What I did just open my contacts in Android phone, and using menu, then go to Accounts. I disabled Sync Contacts in the Sync settings of each Google accounts and only activate sync contacts with 1 Google accounts that considered as primary by me.

I restarted device, and missing contacts problem in my Android phone then gone.

Wednesday, September 24, 2014

How to Upgrade Firmware Samsung Galaxy Note 3 Neo

For some reason the firmware of our devices will be upgraded periodically. I have Samsung Galaxy Neo 3 (SM-N750) that check the update regularly. I did upgrade using phone, and then at the last update I got error and the phone ask me to upgrade using Samsung Kies. I downloaded Samsung Kies 3 that suitable for Samsung Galaxy Note 3 Neo. After connect the device to the PC using cable, I got my phone connected with Kies 3.


Then, Samsung Kies software give me notification that my Samsung Galaxy Note 3 Neo need a firmware upgrade. I clicked ‘'update” button.


The software give me caution and ask me to checked that I have read all information on upgrade process and sign agreement by clicking radio button in their form.


Then, Samsung Kies prepare for firmware upgrade by downloading firmware upgrade components.


Samsung Kies downloaded file for firmware upgrade. The software ask me to not disconnect cable connected to the PC to avoid interrupted upgrade.


During upgrade process, the Samsung device will be restarted few times. Then Samsung Kies will give information that upgrade process succesfully completed.


Just restart device, disconnect and reconnect the cable, and upgrade is done.

Thursday, September 18, 2014

How to Get Website With One Million Page Views Per Month

Today I open my Google Analytics account and got one of my web portal reach 1 million page views in last 30 days. I don’t publish the website address because this website is just experimental website created by me less than 1 year ago. Here is the screenshot of Google Analytics account, and I think it’s amazing.


I didn’t do any off site SEO or something, but I just tried to:

  1. Manage daily regular posting.
  2. Promotion: AdWords with budget no more than 30 clicks per day.

The traffic increased steadily and now reach my target of 1 million page views. So, I have conclusion that regular update is one of the factors that can affect traffic of the website because of returning visitors.

Wednesday, September 10, 2014

How To Set Squid 3 Prefer IPv4 Network

If you have Squid 3 server and your server connected to IPv6 network, Squid 3 will prefer to access IPv6 as default. When the IPv6 network is unreachable, it will tried to access the IPv4 address.

To make Squid 3 prefer IPv4 instead of IPv6, just put these lines in squid.conf:

dns_v4_first on

This configuration line controls whether IPv4 or IPv6 connection is attempted first when contacting servers and peers. Then, restart squid 3 service, or, if you want to reload configuration seamlessly, type command:

squid3 –k reconfigure

Squid will still perform both IPv6 and IPv4 DNS lookups before connecting to the destination server.

Tuesday, September 9, 2014

How to Make Ubuntu Prefer A (IPv4) DNS Lookup Over AAAA (IPv6)

I have Ubuntu server with both IPv6 and IPv4. IPV6 queries made before IPV4 and they where wasting resources, and also there is still no route to some network. After read from some web resources, I got that  it's the standard to prioritize IPv6 over IPv4.

I did changed my /etc/gai.conf (gai stands for getaddrinfo, the standard system call for resolving host names). For sites which prefer IPv4 connections change the last line to:

precedence ::ffff:0:0/96 100

And then, my Ubuntu server query A records (IPv4) before AAAA records (IPv6) when access domains.

Monday, September 8, 2014

How to Set Unifi DHCP Option 43 on MikroTik

We installed Unifi Pro AP in our client’s office to provide wireless access to employees. The network diagram as follow (I’ve changed the configuration to fake IP address because of our client privacy and another security reason). The Unifi Controller in this configuration have public IP address that can accessed anywhere in the world that have internet connection.


To make Unifi Pro access point can adopted by Unifi Controller, I make DHCP in MikroTik Cloud Switch series, with add DHCP option code 43 using MikroTIk Terminal. Unifi introduced the usage of DHCP Option 43 which is used to provide clients and devices on a network the ability to locate the Unifi Controller.

Option 43 value in MikroTik DHCP will be "0x0104" + the HEX of the IP, for example in this network converted to 80C7EEEC. Just search “Convert IP to Hexadecimal IP” and you will find so may converter tools in the Internet. After DHCP in MikroTik is set and computer that use DHCP can access the Unifi Controller port 8080 (in this example is “”), type command in MikroTik Terminal to add DHCP option 43:

/ip dhcp-server option add code=43 name=unifi value=0x0104080C7EEEC
/ip dhcp-server network set 0 dhcp-option=unifi

After turn on the system, Unifi Pro AP will be shown in the Unifi Controller automatically. Unfortunately my configuration was not working. I tried more than half day just to figured out what happen. Then I just reset the Unifi Pro AP by push reset button and then it works. The problem was (maybe) Unifi AP adopted (tested by supplier) before it arrived to my client’s office. New version of Unifi Controller will not detect AP that has adopted by another Controller.